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➢ Tragen Sie als URL die Adresse http://www.zeos.de/update/zen/  ein.

➢ Beenden Sie den Dialog mit Finish.

Die zeos Update-Site wird jetzt in der Feature Updates View angezeigt. Unterhalb des zeos-
Knotens sieht der aufgeklappte Installations-Baum für Eclipse 2 nun folgendermaßen aus:

Lesen Sie nun bitte weiter bei Start der Installation für Eclipse 2.x.

Installation als Download für Eclipse 2.x (alternativ)

Wenn die Installation über die zeos Update-Site nicht möglich ist, laden Sie zuerst das In-
stallationspaket (ZIP) von

http://www.zeos.de/support/download/

auf Ihren Rechner herunter und packen es in ein beliebiges Verzeichnis aus. In die Feature
Updates (View) links unten navigieren Sie dann über My Computer bis zu diesem Verzeichnis.
Hier wird nun ebenso wie im Bild oben ein zeos-Knoten für Eclipse 2 angezeigt. Die
ausgepackten Dateien können Sie nach der Installation wieder entfernen.

Start der Installation für Eclipse 2.x

Selektieren Sie nun unterhalb des Knotens zen Developer for Eclipse 2 den Knoten
zen Developer 2.x.y (x und y stehen für die jeweils aktuelle Version). 

Um den Installationsvorgang zu starten, klicken Sie jetzt rechts auf den Button Install Now. In
dem Wizard-Dialog, der im Anschluß erscheint, müssen Sie nur noch dem Lizenzvertrag zu-
stimmen. Die Install Location auf der folgenden Seite belassen Sie auf dem Standard-Pfad.
Mit Klick auf Finish/Install wird Eclipse den zen Developer Plugin von der zeos Website laden
(bzw. vom lokalen Rechner) und in den Verzeichnissen

• eclipse/features

• eclipse/plugins

speichern. Im Anschluß lassen Sie Eclipse auf Nachfrage einen Neustart ausführen.

Lizenz-Datei

Falls dies eine Erstinstallation ist, erinnert beim Restart zunächst ein Dialog daran, daß der
zen Platform license key noch nicht installiert wurde. Im Anschluß zeigt Eclipse die Welcome-
Page des zen Developer an.

Kopieren Sie jetzt bitte die Lizenz-Datei, die Sie von uns erhalten haben, in das Eclipse-Unter-
verzeichnis 

plugins/de.zeos.zenit.lib.runtime_2.x.y

wie auf der Welcome-Page angegeben. x und y stehen dabei für die gerade installierte
Version des zen Developers.

Sollten Sie noch keine Lizenz-Datei angefordert haben, so können Sie dies unter

http://www.zeos.de/support/download/license.php

nachholen.

Eclipse und der zen Developer Plugin sind damit fertig installiert. Die Release Notes für diese
Version finden Sie im Eclipse-Unterverzeichnis plugins/de.zeos.zenit_2.x.y.

2.4 Installation des zen Developer für Eclipse 3
Starten Sie nun bitte Eclipse. Wenn dies der erste Eclipse-Start ist, wird zunächst der
Workspace Launcher angezeigt. Hier können Sie angeben, wo Ihre Arbeitsdateien abgelegt
werden sollen. Mit Use this as the default and do not ask again können Sie diese Einstellung
als Standard festlegen. Anschließend sehen in der Eclipse-Workbench eine Welcome-Page
mit Informationen über Eclipse. 
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Abbildung 1
Bookmark für die zeos Update-Site

http://www.zeos.de/support/download/
http://www.zeos.de/support/download/license.php


Um den zen Developer Plugin zu installieren, starten Sie den Installationsvorgang über
Help->Software Updates->Find and Install. Es öffnet sich der Wizard Install/Update. Hier
wählen Sie Search for new features to install.

Installation über die Update Site für Eclipse 3.x (empfohlen)

Auf der folgenden Seite tragen Sie über den Button New Remote Site... die Update-Site für
den zen Developer Plugin ein, von der der Plugin dann automatisch heruntergeladen und
installiert wird.

➢ Geben Sie als Namen für die Update-Site zeos  ein.

➢ Tragen Sie als URL die Adresse http://www.zeos.de/update/zen/  ein.

➢ Beenden Sie den Dialog mit OK.

Die zeos Update-Site wird jetzt im Wizard angezeigt. Klappen Sie nun bitte den zeos-Knoten
für Eclipse 3 auf und lesen Sie dann weiter bei Start der Installation für Eclipse 3.x.

Installation als Download für Eclipse 3.x (alternativ)

Wenn die Installation über die zeos Update-Site nicht möglich ist, laden Sie zuerst das In-
stallationsarchiv (ZIP) von

http://www.zeos.de/support/download/

auf Ihren Rechner herunter und speichern es in ein beliebiges Verzeichnis. Im
Installationswizard wählen Sie dann über den Button New Archived Site das
Installationsarchiv aus. Dieses können Sie nach der Installation wieder entfernen. 

Start der Installation für Eclipse 3.x

Im Installationswizard selektieren Sie nun unterhalb des Knotens zeos den Knoten
zen Developer for Eclipse 3. Über den Button Next kommen Sie auf die nächste Seite, wo Sie
das Feature zen Developer auswählen. Um den Installationsvorgang zu starten, klicken Sie
noch einmal auf den Button Next. Im Anschluß müssen Sie nur noch dem Lizenzvertrag zu-
stimmen. Die Install Location auf der folgenden Seite belassen Sie auf dem Standard-Pfad.
Mit Klick auf Finish wird Eclipse den zen Developer Plugin von der zeos Website laden (bzw.
vom lokalen Rechner) und in den Verzeichnissen

• eclipse/features

• eclipse/plugins

speichern. Im Anschluß lassen Sie Eclipse auf Nachfrage einen Neustart ausführen.

Lizenz-Datei

Seit Eclipse 3 wird ein neu installierter Plugin nicht mehr automatisch aktiviert. Wählen Sie
daher bitte manuell über Window->Open Perspective->Other den zen Developer aus.

Falls dies eine Erstinstallation ist, erinnert zunächst ein Dialog daran, daß der zen Platform
license key noch nicht installiert wurde.

Kopieren Sie jetzt bitte die Lizenz-Datei, die Sie von uns erhalten haben, in das Eclipse-Unter-
verzeichnis 

plugins/de.zeos.zenit.lib.runtime_2.x.y

mit der höchsten Versionsnummer. x und y stehen dabei für die gerade installierte Version
des zen Developers.

Sollten Sie noch keine Lizenz-Datei angefordert haben, so können Sie dies unter

http://www.zeos.de/support/download/license.php

nachholen.

Eclipse und der zen Developer Plugin sind damit fertig installiert. Die aktuellen Release Notes
für diese Version finden Sie ebenso im Eclipse-Unterverzeichnis plugins/de.zeos.zenit_2.x.y
mit der höchsten Versionsnummer.

3 Vorbereitungen
Die zen Perspective sollte jetzt aktiviert sein. Welche Perspective jeweils aktiv ist, sehen Sie
in der Shortcut Bar, die sich per Standard am linken Rand von Eclipse befindet (siehe
Abbildung 2).

e3e3e3e3e3e3e3e3e3 Ab Eclipse 3 befindet sich die Shortcur Bar am oberen rechten Rand. Zudem zeigt
sie für jedes Icon den Namen der Perspective. Wenn Sie mit der rechten
Maustaste auf die Shortcur Bar klicken, können Sie diese über Dock On -> Left
nach links setzen und die Namensanzeige abschalten.

Der Name der aktiven Perspective wird in der Titelzeile angezeigt. Wenn Sie mit der Maus
über einem Icon der Shortcut Bar stehen bleiben, wird der Name der jeweiligen Perspective
auch als Tooltip eingeblendet. Welche Perspectives vordefiniert sind, sehen Sie im Menü
Window->Open Perspective.
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�
In einer Perspective werden Layout und Position aller Eclipse-Fenster (Editor &
Views) definiert, die logisch zusammengehören. Indem Sie in einer Perspective
die Anordnung des Editors/der Views ändern, Views aus- oder andere Views ein-
blenden, können Sie eine Perspective Ihren Wünschen nach anpassen. Über den
Befehl Window->Reset Perspective kann die aktivierte Perspective jederzeit
wieder auf den initialen Zustand zurückgesetzt werden.

zen Perspective

Die Modellierung einer zen-Anwendung findet immer in der zen Perspective statt. Eclipse mit
aktivierter zen Perspective ist in Abbildung 3 dargestellt.

Am äußersten linken Rand sieht man die Shortcut Bar für die Umschaltung der Perspectives,
die zen Perspective ist aktiv. Rechts davon ist der Package Explorer für die Navigation in-
nerhalb der Projekte, gerade ist nur Projekt „tutorial“ geöffnet. Rechts oben ist ein zen Editor
„tutorial.zen“ geöffnet, auf dem Reiter daneben sieht man einen weiteren Editor
„Banking.java“. Im rechten unteren Drittel sind alle Views des zen Developers positioniert,
die Resource View ist gerade aktiv. Alle weiteren Views liegen momentan hinter der
Resource View, unter anderem die Workflow View und die Action View.
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Abbildung 3
Übersicht über den zen Developer

Abbildung 2
Perspective-Icons in der Shortcut Bar am linken Rand, die

zen Perspective ist aktiv.



e3e3e3e3e3e3e3e3e3 Seit Eclipse 3 sind die Reiter für die Aktivierung der Views (im rechten unteren
Drittel) über den Views angeordnet. Die Position können Sie unter
Window->Preferences im Bereich Workbench->Appearance konfigurieren.

Anlegen eines zen-Projekts für das Tutorial

Es existiert kein spezieller Projekt-Typ für zen-Anwendungen, stattdessen wird immer ein
Standard Java-Projekt verwendet, da der Business Code einer zen-Anwendung auch in Java
implementiert wird.

➢ Erstellen Sie ein neues Java-Projekt über den Wizard File->New Project...

➢ Als Typ wählen Sie Java Project und geben als Projekt-Namen tutorial  an.

➢ Optional: Wenn Sie das Projekt professionell strukturieren wollen, sollten Sie für Java-
Sourcen ein eigenes Verzeichnis vorsehen. Klicken Sie hierzu auf Next und wählen Sie
den Button Add Folder... im Reiter Source. Hier legen Sie mit Create New Folder... ein
neues Verzeichnis src  an. Bestätigen Sie den Vorschlag von Eclipse, ein Verzeichnis bin
für die kompilierten Klassen anzulegen (Ergebnis: siehe Abbildung 4).

e3e3e3e3e3e3e3e3e3 Seit Eclipse 3 können Sie nach Add Folder... direkt ein neues Source-Verzeichnis
angeben.

➢ Beenden Sie dann den Projekt-Wizard mit Finish. Eclipse schlägt vor, zur Java Perspective
zu wechseln. Lehnen Sie dies ab, um weiterhin in der zen Perspective zu bleiben.

In dem erstellten Projekt können Sie nun zen-Anwendungen erstellen, was in den folgenden
Kapiteln ausführlich beschrieben wird.

Eclipse-Workspace

Eclipse verwaltet alle Projekt-Ressourcen in einem sogenannten Workspace. Dazu wird
automatisch ein Verzeichnis workspace angelegt. Sofern kein spezielles Verzeichnis explizit
angegeben wurde, befindet es sich unter

• Windows: Im Installationsverzeichnis von Eclipse

• Linux/UNIX: Im working directory bzw. in dem Verzeichnis, aus dem Eclipse gestartet
wurde

Das neu angelegte Projekt tutorial liegt ebenso im Workspace wie auch zusätzliche Tutorial-
Verzeichnisse, die automatisch bei der Installation des zen Developers angelegt wurden:

• zen-banking: Eine komplette Version des Tutorial-Projekts. Dies können Sie später über
File->Import...->Existing Project into Workspace importieren und ausprobieren.

• zen-db: Hier legt die mitgelieferte, fertig konfigurierte Datenbank hsqldb ihre Daten ab.
Diese dient dem zen Developer als Repository für die Modellierung als auch für die
Business-Daten bei der Implementierung des Business Codes. Die Datenbank läuft im
Hintergrund und muß nicht weiter beachtet werden.
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Abbildung 4
Ausgefüllter Dialog: New Java Project



4 Erstellen der ersten lauffähigen Anwendung
Im folgenden wird nun die Online-Banking-Anwendung in dem eben erstellten Projekt
angelegt und dann Schritt für Schritt erweitert.

4.1 Anlegen der zen-Anwendung
Stellen Sie sicher, daß Sie sich in der zen Perspective befinden oder wechseln Sie über die
Shortcut Bar in diese. Nun legen Sie eine neue zen-Anwendung mit Hilfe eines Wizards an.

➢ Selektieren Sie das Projekt tutorial.

➢ Wählen Sie im Menü File -> New den Typ zen Application. Daraufhin erscheint der
zen Application Wizard. Als Projekt ist tutorial vorausgewählt.

Beim Anlegen der ersten zen-Anwendung in einem Java-Projekt muß noch die zen-
Konfiguration erzeugt werden.

�
Eine zen-Anwendung benötigt verschiedene Konfigurationsdateien. Diese müssen
vorhanden sein, damit eine zen-Anwendung geöffnet, bearbeitet und ausgeführt
werden kann. Informationen zu Details der zen-Konfiguration entnehmen Sie bitte
dem zen Platform Developers Guide.

➢ Erstellen Sie eine initiale zen-Konfiguration, indem Sie auf den Button Create klicken.

➢ Ändern Sie den Namen der zen-Datei in tutorial.zen  und wählen Sie als Repository den
Eintrag zen.repository  für Ihre Anwendung aus. Als Anwendungsnamen vergeben Sie
ebenfalls tutorial  (Ergebnis: siehe Abbildung 5)

�
Das Repository ist die Datenbank, in der die Modelldefinition einer zen-
Anwendung abgelegt wird. Der Eintrag zen.repository zeigt auf die mitgelieferte
filebasierte Datenbank hsqldb. Wie Sie stattdessen eine eigene Datenbank als
Repository einrichten, entnehmen Sie bitte dem zen Platform Developers Guide.

➢ Wählen Sie Finish.

Daraufhin wird eine leere zen-Anwendung erzeugt und automatisch geöffnet. Jetzt sind alle
Vorbereitungen abgeschlossen und die Tutorial-Anwendung kann erstellt werden. Dazu wird
in den nächsten Schritten zuerst ein Datenmodell der Anwendung erstellt. Anschließend wird
der Workflow der Anwendung modelliert.

�
Sie können die Durchführung des Tutorials jederzeit unterbrechen. Speichern Sie
dazu die Anwendung wie gewohnt über das Menü File->Save. Einmal
geschlossene  zen-Anwendungen öffnen Sie wie immer per Doppelklick oder im
Kontext-Menü der entsprechenden Datei, in diesem Fall von tutorial.zen. Setzen
Sie das Tutorial dann einfach an der gleichen Stelle fort, an der Sie aufgehört
haben.
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Abbildung 5
Ausgefüllter Dialog: New zen Application



4.2 Definition des Datenmodells
Vorüberlegungen

Im ersten Schritt wird das Datenmodell angefertigt. Hierzu sind einige Vorüberlegungen
nötig. In einer Banking-Anwendung werden z.B. folgende Objekte benötigt:

• Konto, z.B. mit Kontonummer und Saldo

• Kontoinhaber, z.B. mit Name und Anschrift

• Überweisungen, jeweils mit Betrag, Verwendungszweck etc.

In diesem Beispiel genügt zunächst die Anlage eines Kontos, bestehend aus Kontonummer
und Saldo. Später wird das Datenmodell Schritt für Schritt erweitert.

�
Das Datenmodell einer zen-Anwendung ist ein hierarchisches Modell, das in der
Data Model View in einer Baumansicht erstellt wird. Es enthält alle Daten, die in-
nerhalb der Anwendung zur Ein- und Ausgabe und als Parameter von
Operationen verwendet werden.
Ausgehend von dem fest definierten Wurzelelement data wird das Modell auf
Basis der elementaren Datenstrukturen Atom, Komposition (Composition) und
Liste (List) definiert.
• Atom: Ein Atom ist ein Blatt des hierarchischen Datenmodells. Atome können

Werte aufnehmen und bekommen einen Datentyp zugewiesen. Im Web-
Umfeld entsprechen Atome z.B. Ein- und Ausgabefeldern.

• Composition: Compositions enthalten keine Werte, sondern dienen zur Glie-
derung unterschiedlicher Elemente. In Compositions können Atome, weitere
Compositions und Lists zusammengefaßt werden.

• List: Eine List wird auf einer Composition oder einem Atom definiert. Zur
Laufzeit kann die List eine beliebige Menge von Elementen des definierten
Typs aufnehmen.

Aus diesen Elementen lassen sich leicht verständliche, äußerst flexible und
darüber hinaus leistungsfähige Datenmodelle erstellen.

Die grundlegenden Objekte werden als Atome definiert. Diese lassen sich über Compositions
und Lists übersichtlich gliedern. Die in diesem Tutorial benötigten Datenelemente können
alle durch die mitgelieferten Datentypen abgebildet werden, so daß keine Definition von
eigenen Datentypen notwendig ist.

�
Die Modellierung einer zen-Anwendung findet zum großen Teil in den Views der
zen Perspective statt. Diese befinden sich im rechten unteren Teil von Eclipse.
Sie werden jeweils in den Vordergrund gebracht, indem man sie über den
entsprechenden Karteireiter aktiviert oder über das Menü Window -> Show View
auswählt.

Das Datenmodell wird in der Data Model View definiert. Aktivieren Sie diese jetzt bitte, um
die Konto-Informationen zu modellieren.

Konto-Informationen

Für das Konto wird eine Composition account  angelegt:

➢ Selektieren Sie das Wurzelelement data . Öffnen Sie das Kontextmenü mit der rechten
Maustaste. Über Add Composition erzeugen Sie eine neue Composition. Diese wird
automatisch unter dem Wurzelelement eingefügt.

➢ Klicken Sie anschließend doppelt auf den Namen der neuen Composition. Dieser wird
damit editierbar. Benennen Sie die Composition in account  um.

➢ Selektieren Sie nun die Composition account  und legen Sie dort über das Kontextmenü
ein neues Atom an. Geben Sie diesem anschließend den Namen number . Wählen Sie im
rechten Teil der View den Datentyp Long  für dieses Atom.
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Abbildung 6
Data Model View: Initiales Datenmodell



➢ Legen Sie ein weiteres Atom unter der Composition account  für den aktuellen
Kontostand an. Dieses Atom nennen Sie balance  und geben ihm den Datentyp Decimal
with 2 digits precision .

Das Ergebnis ist in Abbildung 6 dargestellt. Das so definierte Datenmodell bildet die
Grundlage für die folgenden Schritte, in denen der Workflow der Banking-Anwendung
definiert wird.

4.3 Definition des Workflows
Jetzt wird ein einfacher Workflow definiert, der nur aus zwei Schritten besteht: Der Benutzer
soll zur Anmeldung an die Banking-Anwendung seine Kontonummer eingeben. Zur Vereinfa-
chung wird in diesem Beispiel auf jegliche Authorisierung verzichtet. Auf der Folgeseite wird
die Kontonummer dann wieder ausgegeben.

�
Der Workflow bestimmt das gesamte Ablaufverhalten einer zen-Anwendung. Er
besteht aus den Zuständen (States Nodes) der Anwendung, die z.B. HTML-
Seiten oder Eingabe- bzw. Ausgabeschnittstellen entsprechen. Die State Nodes
werden durch Übergänge (Transitions) miteinander verbunden. Der Wechsel
von einem State in den nächsten kann nur durch eine Aktion (Action) ausgelöst
werden, die dazu einem Übergang zugewiesen wird.

Die Definition des Workflows erfolgt visuell im zen Editor. Die genauen Eigenschaften der
Workflow-Elemente können dabei in der Workflow View editiert werden. Bringen Sie diese
hierzu in den Vordergrund.

State Nodes

➢ Zeichnen Sie im zen Editor einen State Node, indem Sie auf der Werkzeugleiste des
zen Editors das State Node-Tool anklicken (siehe Abbildung 7) und dann an einer freien
Stelle im Editor ein Rechteck aufziehen.

Anschließend geht der zen Editor automatisch wieder in den Select-Modus zurück.

➢ In der Workflow View ändern Sie den Namen dieses Nodes in start . Die Eingabe
schließen Sie mit Return ab. Ebenso stellen Sie in der Workflow View als Gate
defaultentry  ein (Ergebnis: siehe Abbildung 8).

�
Die Gate-Eigenschaft von State Nodes legt fest, wie ein Workflow von einem
Benutzer betreten und verlassen werden kann
• default: normaler State Node innerhalb eines Workflows

• defaultentry: zentraler Standard-Einsprungpunkt in einen Workflow

• entry: (zusätzlicher) Einsprungpunkt in einen Workflow

• exit: Aussprungpunkt aus einem Workflow
Weitere Informationen entnehmen Sie bitte dem zen Platform Developers Guide

Der neue State Node wird vorübergehend als fehlerhaft markiert, weil er noch keine aus-
gehende Transition hat.
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Abbildung 7
Erstellen eines State Nodes



Dieser State Node stellt den Einsprungpunkt in den Workflow dar. Als nächstes folgt ein State
Node, auf dem der Nutzer seine Kontonummer eingeben soll.

➢ Legen Sie diesen neuen State Node nun an und nennen Sie ihn login . Die Gate-
Eigenschaft wird diesmal auf default  belassen.

➢ Als dritten State Node legen Sie nun noch menu an, ebenfalls ohne besondere Eigen-
schaften (Ergebnis: siehe Abbildung 9).

Transitionen

Die Übergänge von einem State Node zum nächsten werden mit dem Transition-Tool des
zen Editors erstellt.

➢ Klicken Sie auf das Transition-Tool, der Mauszeiger bekommt nun ein Steckersymbol.

➢ Klicken Sie dann auf State Node start , um den Beginn der Transition festzulegen, und
dann auf den State-Node login . Damit ist definiert, daß es einen Übergang von start
auf login  gibt, der z.B. durch eine Benutzer-Interaktion ausgelöst werden kann.

➢ Ebenso verbinden Sie den State Node login  mit dem State Node menu (Ergebnis: siehe
Abbildung 10).

�
Um Workflow-Elemente zu löschen, egal ob State Nodes, Decision Nodes oder
Transitionen, markieren Sie das Element und löschen es dann über das Kontext-
menü, über Edit->Delete oder mit Hilfe der Taste Entf/Del. Generell kann jede
Operation auch über Undo/Redo rückgängig gemacht oder wiederhergestellt
werden.
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Abbildung 8
Workflow View und zen Editor mit dem ersten State Node

Abbildung 9
zen Editor mit den ersten drei State Nodes



Wenn die State Nodes verbunden werden, verschwinden automatisch ihre Warnungs- und
Fehlermarkierungen.

4.4 Verbinden von Datenmodell und Workflow
Sie haben inzwischen ein Datenmodell und ein Workflowmodell erstellt. Nun werden Daten-
modell und Workflow miteinander verbunden, um zu definieren, in welchem State Node
welche Daten angezeigt bzw. als Eingabe akzeptiert werden.

➢ Setzen Sie den zen Editor durch Anklicken des Select-Tools in den Select-Modus.

Auf der Seite login soll die Kontonummer als Eingabefeld angezeigt werden. Die
Kontonummer wird also als Eingabe (In) und zur Anzeige als Ausgabe (Out) definiert. Hierzu
aktivieren Sie die Data Model View.

➢ Selektieren Sie im zen Editor den State Node login . Dadurch können Sie die Ein- und
Ausgabe-Elemente für diesen State Node modellieren.

➢ In der Data Model View klicken Sie dann auf das Element number  und aktivieren Sie in
dieser Zeile die Checkboxen in den Spalten In  und Out  (Ergebnis: siehe Abbildung 11).

Auf der Seite menu soll die eingegebene Kontonummer erscheinen, aber nicht als Eingabefeld
behandelt werden.

➢ Selektieren Sie dazu jetzt den State Node menu und markieren Sie das Element number

für diesen State Node diesmal nur als Out . (Ergebnis: siehe Abbildung 12).
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Abbildung 11
Zuordnung von In und Out auf dem State Node „login“

Abbildung 10
Workflow im zen Editor mit Transitionen



➢ Speichern Sie das Modell jetzt über das Menü File->Save ab.

Sie haben nun alle Basisinformationen für einen ersten Start der Anwendung definiert.
Eclipse aktiviert im Anschluß eventuell die Task View. Diese wird vorerst nicht benötigt.

4.5 Hinweise für Entwicklung in anderen Sprachen
Die zen Platform unterstützt die Entwicklung von mehrsprachigen Anwendungen in vollem
Umfang. Sämtliche Ressourcen für die Anzeige, z.B. Texte, Bildpfade, etc. können in
verschiedenen Lokalisierungen hinterlegt werden. Eine Lokalisierung ist immer eine
komplette Kombination aus Land und Sprache (z.B. ist Deutsch (Deutschland) eine von
Deutsch (Österreich) verschiedene Lokalisierung). Wird die Anwendung dann zur Laufzeit in
einer bestimmten Lokalisierung ausgeführt, werden automatisch die passenden Ressourcen
angezeigt. Die mitgelieferten Datentypen für Atome berücksichtigen ebenfalls die
Lokalisierung, so daß Benutzereingaben zur Laufzeit in der entsprechenden Lokalisierung
erfolgen können.

�
Zur Unterstützung der Entwicklung und Ausführung von mehrsprachigen
Anwendungen werden im zen Developer folgende Sprach- und
Ländereinstellungen  unterschieden:
• Default Runtime Locale: Diese Einstellung bestimmt die Lokalisierung, in der

die Anwendung standardmäßig abläuft. Die Default Runtime Locale wird in
der Application View eingestellt. Für andere definierte Lokalisierungen muß
die Anwendung dann mit speziellen Parametern aufgerufen werden. Nähere
Informationen hierzu finden Sie im zen Platform Developers Guide.

• Entwicklungslocale: Diese Einstellung erleichtert während der Modellierung
einer Anwendung die Eingabe von sprachspezifischen Ressourcen und Daten.
Die Entwicklungslocale wird im zen Developer in der Toolbar am oberen Rand
durchgeführt und hat keinen Einfluss auf das Laufzeitverhalten der erstellten
Anwendung.

Für die korrekte Ausführung einer Anwendung müssen alle verwendeten Ressourcen in der
gewünschten Lokalisierung vorliegen. Der zen Developer wird bereits mit einigen
vorbereiteten Ressourcen ausgeliefert. Diese liegen in Deutsch (Deutschland) und
Englisch (Vereinigte Staaten) vor. Wenn ihr Computer mit einer anderen Spracheinstellung
konfiguriert ist, empfehlen wir Ihnen, eine der beiden mitgelieferten Lokalisierungen zu
verwenden.

➢ Aktivieren Sie die Application View. Stellen Sie sicher, das hier Deutsch (Deutschland)
oder Englisch (Vereinigte Staaten) als Default Runtime Locale ausgewählt ist.

➢ Stellen Sie den zen Developer mittels der Auswahlbox in der Toolbar auf die gleiche
Locale (Ergebnis siehe Abbildung 13).
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Abbildung 12
Zuordnung der Out-Elemente auf dem State Node „menu“



Wenn Sie Änderungen an der Default Runtime Locale vorgenommen haben, speichern Sie
das Modell erneut.

4.6 Starten und Testen des Modells
Das Modell kann nun bereits ausgeführt werden. Hierzu muß nur noch ein so genannter
Debug-Launch in Eclipse erstellt werden.

Debug-Launch
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Abbildung 14
Ausgefüllter Dialog: Debug Launch

Abbildung 13
Die Default Runtime Locale und die Entwicklungslocale (Auswahlbox am oberen Rand) sollten auf

Deutsch (Deutschland) stehen



➢ Geben Sie der Konfiguration den Namen zen Tutorial . Als Projekt geben Sie tutorial

an. 

➢ Wählen Sie die Option Include external jars when searching for a main class und klicken
dann auf den Button Search... neben der Eingabezeile. Wählen Sie hier die Klasse
TomcatStart  (aus dem Archiv zenapi.jar) aus (Ergebnis: siehe Abbildung 14).

Start der zen-Anwendung

➢ Starten Sie anschließend die zen-Anwendung mit Debug.

Danach erscheint eine Dialogbox mit der Warnmeldung, daß die Anwendung noch Fehlermar-
kierungen enthält. Das liegt daran, daß bisher keine Behandlung von Anwendungsfehlern
modelliert wurde. Dies ist für den ersten Start noch nicht nötig, wird aber später nachgeholt.
Sie können die Warnmeldung also schließen und im Moment ignorieren.

Eclipse wechselt nun automatisch zur Debug Perspective. Warten Sie nun einige Sekunden,
bis der Debug-Prozess gestartet ist. Wenn Sie in der Console View die Zeile

[TomcatStart]  Tomcat is up & running.

sehen, ist die zen Engine korrekt gestartet (siehe Abbildung 15).

e3e3e3e3e3e3e3e3e3 Seit Eclipse 3 findet kein automatischer Wechsel zur Debug Perspective mehr
statt. Erst wenn ein Breakpunkt erreicht wird, fragt Eclipse 3 nach, ob gewechselt
werden soll. Man muß daher manuell in die Debug Perspective wechseln.

Die zen Engine läuft solange weiter, bis Sie diese explizit stoppen oder Eclipse beendet wird.
Ob eine zen Engine läuft, sehen Sie auch in der Debug View links oben: Wenn dort unterhalb
des Knotens zen Tutorial einzelne aktive Threads (nicht terminated) zu sehen sind, läuft die
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Abbildung 16
Debug View: Beenden des Debugprozesses

Abbildung 15
Debug Perspective mit laufender zen Engine bzw. Tomcat



zen Engine (siehe Abbildung 16). Die Änderungen am Modell werden nach dem Speichern
automatisch mit einer laufenden zen Engine abgeglichen, sie muß für den Test einer
Modifikation daher nicht erneut gestartet werden.

Um die die zen Engine anzuhalten, klicken Sie in der Debug View einfach auf den Stop-Button
(siehe Abbildung 16).

➢ Zum Testen der Anwendung klicken Sie nun mit der rechten Maustaste auf den State
Node start und wählen Sie im Kontextmenü den Eintrag Launch Browser from „start“....
Dadurch wird ein Browser mit der Einstiegsseite dieser zen-Anwendung geöffnet.

Wenn Sie einen externen Browser manuell starten wollen, lautet die URL:

http://localhost:8989/zen/tutorial/zen.repository

�
Je nach Betriebssystem bringt sich Eclipse nach dem Start des Browsers eventuell
selbständig wieder in den Vordergrund und überdeckt dadurch den soeben gest-
arteten Browser.

Test der zen-Anwendung

Sie sehen das Eingabefeld für die Kontonummer. Am oberen Rand befindet sich ein Submit-
Button mit der Aufschrift dummy_action (siehe Abbildung 17).

�
Die HTML-Ausgabe wird automatisch über ein XSL-Stylesheet erzeugt, ohne daß
die HTML-Seiten per Hand definiert werden müssen. Hierfür wird standardmäßig
ein generisches Stylesheet generic.xsl genutzt, das die Visualisierung anhand des
Datenmodells erzeugt. Das Stylesheet wird in der Application View eingestellt
und kann natürlich auch durch ein eigenes ersetzt werden.

➢ Geben Sie nun in das Feld „Hallo“ ein und senden Sie das Formular mit dem Submit-
Button ab.

Das Feld wird rot unterlegt und die Fehlermeldung „Format ungültig“ erscheint. Das liegt
daran, daß das Feld number mit dem Datentyp Long definiert wurde und somit nur Zahlen-
eingaben akzeptiert.

�
Die Fehlermeldungen von Datentypen können Sie selbstverständlich selbst de-
finieren. Die Verwaltung von Datentypen geschieht in der Datatype View, Fehler-
meldungen werden in der Resource View definiert.

➢ Geben Sie nun eine Zahl ein und senden das Formular erneut ab.

Nun wird in den State Node menu gewechselt, die von Ihnen eingegebene Zahl erscheint als
einfache Textausgabe auf der nächsten Seite.

➢ Schließen Sie den Browser.

4.7 Anwendung zur Laufzeit ändern
Alle Änderungen am Anwendungsmodell können grundsätzlich zur Laufzeit erfolgen. Nach
dem Speichern des Modells sollte dann jeweils ein neuer Browser gestartet werden.

Im folgenden werden nun die Eigenschaften des Datenmodells verändert und in die laufende
Anwendung übertragen.

Pflichtfelder

➢ Starten Sie einen neuen Browser über das Kontextmenü auf dem State Node start.
Lassen Sie diesmal das Eingabefeld leer und schicken Sie die Seite ab.

Es wird nun wieder in den State Node menu gewechselt, die Ausgabe für die Kontonummer
number ist leer. Im nächsten Schritt soll verhindert werden, daß die Seite login ohne Angabe
einer Kontonummer verlassen werden kann.

➢ Schließen Sie den Browser wieder.
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Abbildung 17
Browser: State Node „login“

http://localhost:8989/zen/tutorial/zen.repository


Im Datenmodell wird hierzu das Feld number als Pflichtfeld deklariert. Wechseln Sie hierzu
aus der Debug Perspective zurück in die zen Perspective und aktivieren Sie die Data Model
View.

➢ Klicken Sie dort auf das Element number  und aktivieren Sie die Checkbox mandatory  auf
der rechten Seite der View.

➢ In der jetzt aktiven Dropdownbox neben der Checkbox wählen Sie Eingabe

unvollständig  als Fehlermeldung.

Dieser Text erscheint jetzt als Fehlermeldung, wenn das Feld vom Benutzer nicht ausgefüllt
wurde.

Änderungen zur Laufzeit übernehmen

➢ Speichern Sie das Modell ab.

Wenn die zen Engine noch läuft, erscheint daraufhin ein Dialog mit der Frage, ob die
laufende Anwendung mit dem geänderten Datenmodell aktualisiert werden soll. Sonst
starten Sie die zen Engine erneut über den Debug-Launch.

➢ Beantworten Sie die Frage mit „Yes“. Starten Sie einen neuen Browser über das Kontext-
menü auf dem State Node start. 

Der Beschreibungstext eines Pflichtfeldes wird vom generischen Stylesheet generic.xsl mit
einem Stern (*) gekennzeichnet. Wenn Sie jetzt die Seite mit leerem Textfeld abschicken,
wird das Feld rot unterlegt und die Fehlermeldung „Eingabe unvollständig“ ausgegeben.

5 Erweiterung der Anwendung
Die folgenden Erweiterungen können Sie jeweils bei laufender zen Engine vornehmen. Wie
oben beschrieben, müssen Sie nach dem Abspeichern des Modells nur den Aktualisierungs-
dialog bestätigen, so daß die laufende Anwendung auf den aktuellen Stand gebracht wird. 

Wenn Sie die zen Engine zwischenzeitlich stoppen, müssen Sie sie über den vorhin konfigu-
rierten Debug-Launch zen Tutorial erneut starten.

5.1 Hinzufügen von State-Resources
Mit einer eindeutigen Überschrift für jede Formularseite wird die Orientierung in der
Anwendung erleichtert. Hierzu wird nun für jeden State Node einen Seitentitel erstellt, der
dann als Überschrift auf der jeweiligen HTML-Seite angezeigt wird.

Wechseln Sie zurück zur zen Perspective und aktivieren Sie die Resource View. Hier werden
z.B. Texte oder Bild-Links erstellt, mit denen Sie Workflow- und Daten-Elemente beschriften
können.

➢ Klicken Sie auf den Reiter State, um eine Ressource für State Nodes zu erzeugen.

➢ Mit der rechten Maustaste klicken Sie in die noch leere Tabelle und wählen aus dem Kon-
textmenü Create.

➢ Für die neue Ressource headline  geben Sie in der Spalte Value als Inhalt Bitte

anmelden ein.

➢ Fügen Sie eine weitere headline-Ressource hinzu, diesmal mit dem Text Herzlich

willkommen!  (Ergebnis: siehe Abbildung 18).

�
Das generische Stylesheet generic.xsl nutzt State-Resources mit dem Namen
headline zum Zeichnen einer Überschrift. Für eine umfassendere
Seitengestaltung können beliebige State-Resources, z.B. Texte und Bilder,
definiert und das Stylesheet darauf abgestimmt werden.
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Abbildung 18
Resource View: Beschriftungen der State Nodes
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