


Table of Contents
1 Overview............................................................................................................................................................................3

2 Installation.........................................................................................................................................................................3

2.1 System requirements................................................................................................................................................3

2.2 Installation of Eclipse................................................................................................................................................3

2.3 Installation of zen Developer for Eclipse 2...............................................................................................................3

2.4 Installation of zen Developer for Eclipse 3...............................................................................................................4

3 Preparations.......................................................................................................................................................................5

4 Creation of first running application..................................................................................................................................8

4.1 Creation of a zen Application....................................................................................................................................8

4.2 Definition of the data model.....................................................................................................................................9

4.3 Workflow definition.................................................................................................................................................10

4.4 Connecting workflow and data model....................................................................................................................12

4.5 Development in different languages......................................................................................................................13

4.6 Launch and test of the model.................................................................................................................................14

4.7 Changes at runtime.................................................................................................................................................16

5 Enhance the application..................................................................................................................................................17

5.1 Adding state resources...........................................................................................................................................17

5.2 Extending the workflow..........................................................................................................................................18

5.3 Extending the data model.......................................................................................................................................20

5.4 Adding element and action resources....................................................................................................................22

5.5 Error handling.........................................................................................................................................................23

6 Programing business logic...............................................................................................................................................25

6.1 Decisions.................................................................................................................................................................25

6.2 Workflow Operations...............................................................................................................................................29

6.3 Business Rules........................................................................................................................................................31

7 Simple persistence via JDBC............................................................................................................................................33

7.1 Store in a database.................................................................................................................................................33

7.2 Load from the database..........................................................................................................................................34

8 Summary..........................................................................................................................................................................37

Appendix.............................................................................................................................................................................38

A Additional Reading.....................................................................................................................................................38

I.zen Platform...........................................................................................................................................................38

II.Eclipse...................................................................................................................................................................38

B FAQ – Frequently Asked Questions............................................................................................................................39



1 Overview
This tutorial explains step by step how to build a web application with the zen Platform, on
the basis of an online banking example. The example application will provide usual functions
like checking the balance, filling in and inspecting transfers, just like a real world banking
application would do. The needed functionality will be added and explained step by step.

2 Installation
The following chapter describes how to install the Eclipse development platform and the
zen Developer plugin for developing applications on the zen Platform.

2.1 System requirements
The minimum requirement in order to install Eclipse and the zen Developer is a Java 2 SDK,
Standard Edition (J2SE SDK) version 1.4.x or higher.

If you haven't installed this JDK yet, you can download it from 

http://java.sun.com/j2se/1.4.2/download.html

for free. Please follow the given instructions. 

2.2 Installation of Eclipse
The zen Developer is a plugin for the freely available development environment Eclipse. You
need an Eclipse-SDK version 2.1.2 or higher. Eclipse 3.x is supported as well.

Installation

If have not installed Eclipse yet, please download the appropriate version from:

http://www.eclipse.org/downloads/

We recommend the so called “Latest Release”. You can find them directly following these
links:

2.1.3: http://download.eclipse.org/downloads/drops/R-2.1.3-200403101828/index.php
3.0.1: http://download.eclipse.org/downloads/drops/R-3.0.1-200409161125/index.php

Eclipse is distributed as ZIP-File without an installer. Simply unpack the contents to your
favored directory.

Starting Eclipse

Eclipse is started using the executable “eclipse”, located in the eclipse directory where you
have unpacked the contents of the ZIP-File.

e3e3e3e3e3e3e3e3e3 The Eclipse 3 GUI is somewhat different from Eclipse 2. This tutorial is based on
Eclipse 2, differences are shown in separate chapters or boxes. If you like to use
Eclipse 3 but want to use the appearance of Eclipse 2, you can do so by choosing
Window->Preferences and selecting Current Presentation : R21Presentation from
the Workbench->Appearance section.

2.3 Installation of zen Developer for Eclipse 2
Please launch Eclipse now. If this is your first Eclipse launch, you will see a welcome page
with some information about Eclipse.

To install the zen Developer plugin, activate the Install/Update-Perspective by choosing Help-
>Software Updates->Update Manager from the menu.

The easiest way to install the zen Developer plugin is by using the zeos-update-site. If you
can't establish a direct internet connection (port 80) from your computer, you can download
the installation package separately. In this case follow the instructions layed out in section
Installation within Eclipse 2 as separate download further below. 

Installation within Eclipse 2.x using the update site (recommended)

On the lower left hand side of the Feature Updates View (see Figure 1) click with the right
mouse button and select New->Site Bookmark.... Now you can enter the update site details
for the zen Developer plugin, needed for automatic download and installation.

➢ Enter zeos  as name for this Update-Site.

➢ Enter the following address as URL http://www.zeos.de/update/zen/  .

➢ Close the dialog by selecting Finish.

The zeos update site is now visible in the Feature Updates View . If you expand the zeos
branch, the installation tree will look like this:
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Please continue now with section Starting the installation within Eclipse 2.x.

Installation within Eclipse 2 as separate download (alternative)

If you can't install zen Developer using the update site, please download the complete
installation package (ZIP) from

http://www.zeos.de/support/download/

and unzip the files in any directory. Within the Feature Updates View of Eclipse you can now
browse your hard disk using the My Computer tree. Please locate the directory containing the
unzipped files. This folder should now show up with zen Developer for Eclipse 2 similar to the
figure above. After finishing the installation, the directory containing the installation files may
be removed.

Starting the installation within Eclipse 2.x

Select the node below zen Developer for Eclipse 2 labeled zen Developer 2.x.y (where x and
y represent the current version)

To actually start the installation, please click on Install Now in the right hand side of the
window. The installation wizard will guide through the remaining steps. Please don't alter the
Install Location during this procedure. By clicking Finish/Install, the zen Developer plugin is
loaded from the zeos website (or your local disk) and installed into the following folders below
your Eclipse installation:

• eclipse/features

• eclipse/plugins

Please restart Eclipse after the installation.

License key

If this is your first installation, Eclipse reminds you that the zen Platform license key has not
been installed so far. After this dialog box you will see the Eclipse welcome page of your
zen Developer.

Please copy the license file you received from us into the following directory below your
Eclipse installation: 

plugins/de.zeos.zenit.lib.runtime_2.x.y

just like mentioned on the Welcome-Page. x and y stand for the highest current installed
version of zen Developer.

If you haven't received a license file so far, you can obtain one from:

http://www.zeos.de/support/download/license.php

After these steps, Eclipse and the zen Developer plugin are installed and operational. You
can find the release notes in the directory plugins/de.zeos.zenit_2.x.y of your Eclipse
installation.

2.4 Installation of zen Developer for Eclipse 3
Please launch Eclipse now. If this is your first Eclipse launch, it will start with the Workspace
Launcher. You have to select, where Eclipse will store your working data and configuration.
By selecting Use this as the default and do not ask again you may set the selected directory
as default directory. After that, you'll see the a welcome page within the Eclipse workbench.

To install the zen Developer plugin, please start the installation process by selecting
Help->Software Updates->Find and Install from the menu. The Install/Update wizard is
shown. Please select Search for new features to install.

Installation within Eclipse 3.x using the update site (recommended)

On the subsequent page please select New Remote Site... and enter the following details for
the update site used to download and install the zen Developer plugin automatically:
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Figure 1
Bookmark for the zeos update site
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➢ Enter zeos  as name for the update site.

➢ Enter http://www.zeos.de/update/zen/  as URL

➢ Close this dialog by clicking OK.

The zeos update site is now displayed within the wizard. Expand the zeos node to see the
node zen Developer for Eclipse 3. Please proceed with the section Starting the Installation
within Eclipse 3.x

Installation within Eclipse 3 as separate download (alternative)

If you can't install the zen Developer plugin using the zeos update site, please download the
complete installation package (ZIP) from

http://www.zeos.de/support/download/

and save it to your local hard disk. Use the button New Archived Site to select this ZIP file.
After the installation has finished, you may remove this file.

Starting the installation within Eclipse 3.x

Now select the node labeled zen Developer for Eclipse 3 below the zeos node within the
installation wizard. By clicking on the button Next you get to the next page where you can
select the zen Developer feature. Follow the remaining steps of the wizard. Please don't alter
the install location. By clicking Finish the zen Developer plugin is loaded from the zeos
website (or your local hard disc) and installed into the following folders below your Eclipse
installation:

• eclipse/features

• eclipse/plugins

Please finish the installation by restarting Eclipse.

License key

A newly installed plugin is not activated by Eclipse 3 by default. Please select zen Developer
from the menu Window->Open Perspective->Other to do so.

If this is your first time installation, a dialog will remind you to install the zen Platform license
key.

Please copy the license file you received from us into the following directory below your
Eclipse installation: 

plugins/de.zeos.zenit.lib.runtime_2.x.y

just like mentioned on the Welcome-Page. x and y stand for the highest currently installed
version of zen Developer.

If you haven't received a license file so far, you can obtain one from:

http://www.zeos.de/support/download/license.php

After these steps, Eclipse and the zen Developer plugin are installed and operational. You
can find the release notes in the directory plugins/de.zeos.zenit.e3_2.x.y of your Eclipse
installation.

3 Preparations
The zen Perspective is now activated. The currently active perspective is indicated on the
shortcut bar at the left edge of the Eclipse screen (see Figure 2).

e3e3e3e3e3e3e3e3e3 The shortcut bar of Eclipse 3 is located at the right top area of Eclipse 3. By
clicking on the shortcut bar with the right mouse button and selecting Dock On
-> Left you can move it to the left edge.

The name of the currently active perspective is displayed in the window title. If you move
your mouse over the icons, the names are displayed as tool tip. You can also use the menu
Window->Open Perspective for switching to defined perspectives.
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�
The layout and position of Eclipse windows (views and editors) that belong to a
logical group are called perspectives. If you change the position of views or
editors or close/disable views, you can always return to the preconfigured layout
by selecting Window->Reset Perspective.

zen Perspective

Modeling a zen Application is always done using the zen Perspective. Eclipse with an active
zen Perspective is shown in Figure 3.

On the left hand side you see the shortcut bar where you can switch between perspectives.
Next to the right you see the Package Explorer used for navigation within your projects. This
screen shot shows only one open project called “tutorial”. On the right side you see the editor
on the upper part currently showing the file “tutorial.zen” and another tab representing
another editor for editing the file “banking.java”. Below the editors all views of the
zen Developer are grouped together. The currently active view is the Resource View. Other
views can be activated by switching the respective tabs of the views.
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Figure 3
Overview zen Developer

Figure 2
Perspective icons on the shortcut bar on the left edge; the

zen Perspective is active.



e3e3e3e3e3e3e3e3e3 Eclipse 3 displays these view tabs on top of the views. You may change this using
the Workbench->Appearance section of the Window->Preferences dialog.

Creating a zen project for the tutorial

There is no special project type for a zen Application. Using a standard Java project is
sufficient as the business code is developed in Java as well.

➢ Create a new Java project by choosing File->New Project...

➢ Choose Java Project as type and name it tutorial .

➢ Optional: If you want a professional structure we recommend a separate directory

containing the source files. To do so click Next and click the Add button on the Source
tab. Now use Create New Folder... to create a directory called src. Confirm the dialog
suggesting a directory bin as output path for the compiled class files (result is shown in
Figure 4).

e3e3e3e3e3e3e3e3e3 Eclipse 3 adds the possibility to use such a layout on the second page of the new
project wizard without the need to manually add a new source folder.

➢ After clicking Finish, Eclipse suggests changing to the Java Perspective. Please choose No

here to stay in the zen Perspective for now.

This project you just created is used to for creating a zen Application explained below in
detail.

Eclipse workspace

Eclipse manages all resources within a so called workspace. It automatically creates a
directory named workspace. If you did not specify a special location this directory is located
under

• Windows: in the installation directory of Eclipse

• Linux/UNIX: in the current working directory, the directory, where Eclipse has been

started

The newly created project tutorial is located below this workspace structure as well as some
of the files that have been installed together with the zen Developer:

• zen-banking: A completed version of the tutorial project. You can explore and try it by

importing it using the menu File->Import...->Existing Project into Workspace 

• zen-db: The integrated hsqldb database is preconfigured to store its files in this directory.

This database is used to as repository for the application model as well user data when
implementing the business code. It is running in background an needs no further
attention.
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4 Creation of first running application
Within the project just prepared before, the online banking application will be created and
enhanced step by step.

4.1 Creation of a zen Application
Please make sure that you have activated the zen Perspective or do so now by clicking on its
icon in the shorcut bar. Now you can create a new zen Application with the aid of a wizard.

➢ Select the project tutorial.

➢ Choose File -> New and the type zen Application from the menu. Now the

zen Application Wizard is displayed. The project tutorial is already filled in.

If you are about to create the first zen Application within a Java project, you need to prepare
a zen Configuration first.

�
A zen Application needs several configuration files. These files must be present
prior to opening, editing or executing a zen Application. For further details about
this configuration please refer to the zen Platform Developers Guide.

➢ Create an initial zen Configuration by clicking the button Create.

➢ Change the filename to tutorial.zen  and choose zen.repository  as repository for

your application and name this application tutorial  (result is shown in Figure 5)

�
The repository is a database where all the model information of a zen Application
is stored. The entry zen.repository refers to the preconfigured file-based hsqldb.
The necessary steps to use a different database are explained in the zen
Platform Developers Guide.

➢ Choose Finish.

An empty zen Application is created and opened automatically. Now that all preparations are
completed, you can start modeling the tutorial application. First the data model is defined in
a few steps, followed by the definition of the workflow.

�
You may pause the tutorial at any time. Save your current work by choosing the
menu File->Save just like in any usual application. You can reopen a previously
closed zen Application by double-clicking or using the context menu on the
corresponding file (in this case the file named tutorial.zen). You may continue
your work just were you left.
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4.2 Definition of the data model
Considerations

In the first step, the data model will be defined. We will figure out what kind of data we may
need in a banking application:

• account information, like account number and balance

• account holder information, like name and address

• transfer including amount, date and note to recipient

In our example we'll start by defining an account consisting of account number and balance.
The data model will be completed step by step afterwards.

�
The data model of a zen Application is hierarchical and therefore displayed in a
tree structure. It consists of all data needed for input, output or as arguments to
operations within the application.
Starting with the fixed root element data the model is defined by basic data
structures like atom, composition and list.

• Atom: an atom is the leaf within an hierarchical data model. Atoms have an

assigned data type and contain values. In a web environment, atoms
represent input and output fields.

• Composition: Compositions do not contain values themselves, they are used

to group different elements together. Compositions may contain atoms, lists
or compositions.

• List: A list is defined on a composition or an atom. During runtime it may

contain an arbitrary amount of elements of the defined type.
Using these elements you can define an easy, well structured and very flexible
data model.

Basic objects are defined as atoms. They may be grouped together using compositions and
lists. The data elements used throughout this tutorial use the shipped data types, so there is
no need to define custom data types.

�
Modeling a zen Application is accomplished by using the views of the
zen Perspective. They are located at the bottom right hand side of Eclipse. Each
of them is brought to front by clicking on the tabs or choosing them from the
menu  Window -> Show View.

The data model is defined using the Data Model View. Activate it now in order to model the
account information.

Account information

The account is created as an composition account :

➢ Select the root element data . Open the context menu by clicking the right mouse button.

Choosing Add Composition creates a new composition which is inserted below the root
element.

➢ Double-click the name of the new composition. The name is now editable. Rename it to

account .

➢ Now select the composition account and create a new atom using the context menu.

Name it number and  choose the data type Long from drop down box on the right side of
the view.

➢ Add another atom to the composition account in order to store the current balance.

Name this atom balance and assign the data type Decimal with 2 digits precision
to it.
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Figure 6
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Figure 6 shows the resulting data model. It is the basic structure used in the following steps
when the workflow is added to the banking application.

4.3 Workflow definition
Now a simple workflow is added consisting of two steps: The user should enter his account
number to log into the application. To keep the example simple we omit any kind of
authorization here. The following page will just display the account number for now.

�
The worklfow is essential to the behavior of a zen Application. It consists of state
nodes, i.e HTML-pages or other input/output interfaces. These state nodes are
connected by transitions. The transition from one state node to another is
activated by an action which is assigned to this transition.

The workflow definition is done in a visual manner using the zen Editor. The properties of the
workflow elements are edited using the Workflow View. Please activate it now.

State Nodes

➢ Draw a state node by clicking on the state node tool in the zen Editor toolbox and then

click and drag a rectangular shape anywhere on the empty editor canvas (see Figure 7).

After drawing the node, the zen Editor resets the state node tool automatically to the Select
mode.

➢ Using the Workflow View, rename the state node to start . Confirm your entry by hitting

the return key. Choose defaultentry as gate from the drop down box in the Workflow
View (result shown in Figure 8).

�
The gate property determines whether a workflow may be entered or left from a
specific state node.

• default: normal state node within a workflow

• defaultentry: state node is the central entry point into a workflow

• entry: (additional) entry point into a workflow

• exit: exit of a workflow

Additional information can be found in the zen Platform Developers Guide.

The new state node is currently marked with an error as there is no attached transition
originating from it.

This state node is now the entry into the workflow. The next state node will provide the ability
for the user to enter his account number.
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Figure 7
Creation of a state node



➢ Draw a new state node and name it login . Don't alter the gate property this time and

keep default .

➢ Draw a third state node named menu, again without the need to change any of the

defaults (result shown in Figure 9).

Transitions

The transitions from one node to another node are done using the Transition tool of the
zen Editor.

➢ Click on the Transition tool, notice the symbolic plug-shape of the mouse cursor.

➢ First click on the node  start  to determine the starting point of the transition. Then click

on the state node login, thus defining a transition from start to login that may be
triggered by the user.

➢ In the same way create a transition from login to the state node menu (result shown in

Figure 10).

�
To delete any workflow element, first select it then delete it either using the
context menu, the Del key or the Edit->Delete menu. Each operation may be
undone or restored using the usual Undo/Redo menu.

After the state nodes have been connected, all warning and error signs disappear
automatically.
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Figure 9
zen Editor showing the first three state nodes



4.4 Connecting workflow and data model
You have just designed a data model and a workflow. Now data model and workflow are put
together in order to define what data is displayed or accepted as input on the state nodes.

➢ Reset the zen Editor to the Select mode by clicking on the Select tool.

The login page should present the account number as an input field. The account number is
therefore going to be defined as In as well as Out. To do so please activate the Data Model
View.

➢ Select the state node login  within the zen Editor. Now you can define the input and

output elements of this state node.

➢ Using the Data Model View, first click on the element number  then tick the check boxes of

this row in the columns In and Out like in Figure 11.

The account number entered by the user should be displayed on the page menu but it is not
an input field there.

➢ Now click on the state node menu and then select the the element number . This time, only

tick the check box Out (result shown in Figure 12).

➢ Save your model by choosing the menu File->Save.
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Figure 11
In and Out properties assigned to the state node „login“

Figure 10
Workflow with transitions



Now everything is in place for a first launch of the application. Eventually Eclipse activates
the Task View after saving the model; you may ignore this for now.

4.5 Development in different languages
The zen Platform supports the development of multi-language applications. All resources
necessary for display, e.g. texts and image paths, can be defined in different locales. A locale
is the combination of a language and a country, therefore English (United Kingdom) and
English (United States) are considered as two different locales. When the application is being
executed in a given locale, all resources will be displayed in this locale automatically. The
provided datatypes of atoms consider the runtime locale as well, so users can input their
data in the runtime locale.

�
To support development and execution of multi-language applications, the
zen Developer uses two different locale settings:

• Default Runtime Locale: This setting determines the locale the application

will use as default at runtime. The Default Runtime Locale is set in the
Application View. For running in other defined localizations, the application
has to be called with special parameters. Additional informations on this topic
can be found in the zen Platform Developers Guide.

• Developer Locale: This setting simplifies the entry of locale-specific resources

and data during modeling. It is selected with the drop down box at the top of
the zen Developer. This setting has no impact on the runtime of the
application.

For correct execution of an application, all used resources have to be present in the desired
locale. The zen Developer is shipped with several predefined resources in German (Germany)
and English (United States). If your computer uses a different setting we recommend the
usage of one of these two locales. Before you continue please check the following:

➢ Activate the Application View and make sure the Default Runtime Locale is either set to

German (Germany) or English (United States)

➢ Select the same locale you set as Default Runtime Locale as Developer Locale from the

drop down box in the tool bar at the top of the zen Developer (result is shown in Figure
13).
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If you changed the Default Runtime Locale, save the application again.

4.6 Launch and test of the model
The model is ready for execution. Just define a new so-called debug launch in Eclipse.

Debug launch

➢ Activate the menu Run -> Debug... Select Java Application and click on New in this

dialog.
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Figure 14
Completed dialog: Debug Launch

Figure 13
zen Developer: Default Runtime Locale and Developer Locale (drop down at top) should be set

to English (Untited States)



➢ Name this configuration zen Tutorial and select tutorial as project.

➢ Select the option Include external jars when searching for a main class and click on the

button Search... next to the input field. Select the class TomcatStart , located in
zenapi.jar (result is shown in Figure 14).

Start of the zen Application

➢ Now start the zen Application by clicking on Debug.

A dialog pops up, warning you that the application has some errors or warnings. The
application still lacks error handling which is not needed for our initial start and will be added
later. Just acknowledge the dialog for now.

Eclipse automatically changes to the Debug Perspective. Wait a few seconds for the debug
process to start. If the line

[TomcatStart]  Tomcat is up & running.

is displayed in the Console View the startup was successfull (see Figure 15).

e3e3e3e3e3e3e3e3e3 Eclipse 3 does not automatically change to the Debug Perspective. Only if a
breakpoint is hit, a dialog will ask if it should be activated now. Therefore you
have to manually change to the Debug Perspective.

The zen Engine is running until explicitly stopped, or the entire Eclipse is closed. To tell if it is
running take a look at the Debug View at the top left area of the Debug Perspective: If there
are still active threads (not marked as terminated) it is still running (see Figure 16). Changes
to the model are automatically reloaded by the zen Engine, so there is no need to restart it
after application modifications.

To stop the zen Engine, click on the red button Terminate of the Debug View (see Figure 16).
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Figure 16
Debug View: Termination of the debug process

Figure 15
Debug Perspective with running zen Engine (using Tomcat)



➢ In order to test your application, right-click on the state node start  and select Launch

Browser from „start“....This will start up your web browser displaying the first page of
your zen Application.

If you want to manually launch an external browser you may use the following URL:

http://localhost:8989/zen/tutorial/zen.repository

�
Depending on your operating system, Eclipse may hide your browser by bringing
itself into foreground. Please check your taskbar of no browser window is visible.

Testing the zen Application

In your browser you can see the input field for the account number. On the top there is a
submit button labeled dummy_action (see Figure 17).

�
The HTML output is generated automatically using xsl-transformation. There is no
need to design HTML-pages manually. The default xsl stylesheet used in these
transformations – named generic.xsl – displays the data using the information of
the data model. The used stylesheet can be selected using the Application View
and may be exchanged by a custom stylesheet easily.

➢ Now type “Hello” into the input field and submit the form using the submit button.

The input field is rendered with a red background, and an error message „Wrong format“ is
displayed. This happens because the field number has been defined with the data type Long
and is therefore only accepting digits as input.

�
The error messages of data type violations are customizable. The data types are
defined in the the Datatype View, error messages are defined via the Resource
View.

➢ Now enter a number and submit the form again.

The application switches to the state node menu and the number you have just entered is
displayed as simple text output.

➢ Now close the browser window.

4.7 Changes at runtime
All changes to the application model may be performed at runtime. However, after saving the
model a new browser instance should be started.

Now some properties are going to be changed and reflected into the running application.

Mandatory fields

➢ Open a new browser window using the context menu of the state node start again. Leave

the input field empty and submit the form.

The application switches again to the state node menu, displaying an empty number field.
This should be prevented by making the account number a mandatory field.

➢ Close the browser window.

Change the perspective from the Debug Perspective back to the zen Perspective and
activate the Data Model View.

➢ Click on the element number and tick the check box mandatory on the right side of the

view.

➢ The dropdown box next to the check box is now active and you can select Missing
required entry.
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Figure 17
Browser: state node „login“

http://localhost:8989/zen/tutorial/zen.repository


This text is displayed as error whenever the user misses to fill in this field.

Applying changes at runtime

➢ Save the model now.

If the zen Engine is still running, a dialog will pop up requesting whether you want to apply
the changes to the running application. Otherwise start the zen Engine again using the
Debug-Launch.

➢ Answer „Yes“ to the question and start a new browser window using the context menu of

the state node start.

The description text of a mandatory field will be automatically rendered with an asterisk (*)
by the stylesheet generic.xsl. If you try to submit the form now without filling in the account
number, the application will remain on the same state node, the field will be displayed with a
red background and the error text “Missing required entry” will be displayed.

5 Enhance the application
The following enhancements may be performed while the application is still running. Just
confirm the dialog to apply the changes after saving.

If you stop the zen Engine in the mean time, you must restart it again using the Debug-
Launch zen Tutorial you have configured previously.

5.1 Adding state resources
Using a descriptive headline for each page greatly improves the usability of the application.
In order to do this, a headline for each state node will be defined. The headlines will be
displayed on top of each HTML-page.

Change back to the zen Perspective and activate the Resource View. This is the place where
texts or image links are defined used later on to label workflow- or data-elements.

➢ Click on the tab State to create a resource used by state nodes.

➢ Right-click into the (empty) table and select Create from the context menu

➢ Fill in Please login  into the column value of the new resource headline .

➢ Add another headline, this time using the text Welcome!  (result shown in Figure 18).

�
The generic stylesheet generic.xsl uses state resources with the name headline
to render a headline onto the pages. For a more complex layout, custom (state)
resources may be defined that an adapted stylesheet may use for texts, images
or the like.

Activate the Workflow View again to assign these new headlines to the according state
nodes.

➢ Select the state node login  in the zen Editor.

➢ Select Please login  from the list of Available Resources of in the Workflow View and add

it to the list of used resources by double-clicking it or using the arrow button (result
shown in Figure 19). You may need to scroll the Workflow View down to see all resources.

➢ Assign the headline Welcome!  to the state node menu in the same way.
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Figure 18
Resource View: labels for state nodes



After saving the model, the headlines will be displayed automatically in the application.

5.2 Extending the workflow
Now the workflow will be extended with another step, providing the user with the ability to
enter a transfer. Make sure the zen Perspective is active, if not change to it.

➢ Draw a new state node in the zen Editor and name it transfer  using the Workflow View.

➢ Draw a transition from the state node menu to the new state node transfer . With this

state node, the user is enabled to enter all the transfer details later.

Actions

In order to manage the transitions and to define specialized behavior on them, an action is
assigned to each transition. Actions have to be defined separately. Activate the Action View
now (see Figure 20). Notice the action dummy_action, which has been assigned to each
transition automatically so far.

�
A possible transition from one to state node to another is defined by a
transition. The actual switch from one state node to the next is triggered by an
action. In a web environment this may be i.e. the click of a submit button. Each
transition is assigned an action.

You will be creating specialized actions that you may assign to the transitions right now.
Using the right mouse button on the action table, you can select Create from the context
menu. The first action will be used for login.

➢ Create a new action.

➢ Change the automatically generated name to login .

➢ In order to create a transfer, create an action transfer  in the same way.

➢ To actually execute the transfer create another action named execute .

➢ In order to cancel a transfer, add the action back  as well. It will be used later on in

several transitions. You should set the Type to nonvalidating for this action only (result
shown in Figure 20).
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Figure 19
Workflow View: label assigned to the state node „login“
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